(English) Internet speed slow and stability issues

  • 12 februari 2020
  • 6 reacties
  • 298 x bekeken

Dear Tele2 - Support Team,

I am reaching out to you because the Internet access at our place is hardly working at the moment. 

As we took over the contract from the previous tenants, it seems that our router is already six years old and might be the source of the problem. The router is an Davolink DV-2020.

In general, the Internet speed, if it is working properly, is sufficient, but currently it takes several seconds and sometimes minutes to open simple webpages which makes the Internet almost useless.

Is there any chance to swap the router with a newer one?

Thank you in advance and best regards!

 


Dit topic is gesloten. Maak een nieuw topic aan als je een vraag hebt.

6 reacties

Reputatie 7
Badge +4

Did you formally take over (so, contract forms via Tele2) or just paying the monthly fee although the name on the contract is still the old tennant.

We formally took over the contract. Means the name on the invoices and also in the Tele2 customer portal were changed.

Reputatie 7
Badge +4

Ok, than you can or wait until a Tele2 moderator will pick up in this topic, or call customer care and ask them to perform a line measurement, THey can see what speed is reaching the modem.  The modem is in most of the times not the bottleneck. 

Did you connect already by a wired cable to the modem? Wifi is unpredictable for speeds. If you do test with wifi, try the wifi optimisation.  Or when the speeds are not good through your house, try the subscription on the smart wifi.

Thanks for your help Eric!

Unfortunately we do not have any devices to use with a wired cable in our household.

However, I think the router should at least provide a stable Wifi connection to the devices in the same room and some minimum speed to load webpages without using any extras such as wifi repeaters.

As I already said, the speed in general is okay as long as it is working properly, but the connection varies from one moment to the other between streaming a video in 1080p works perfectly fine and Wifi also works on the other side of the apartment and an hour later webpages are not even loading when the connected device is located in the same room. 

For example right now, when writing my answer, the “Send”-Button is not loading so that I have to cut the text, reload the page, insert it again and then hope that the button loads this time. I am the same room as the router, 4/4 bars of the Wifi connection.

For troubleshooting, I already restarted the router several times, restarted the devices, tried to optimise the wifi (using less occupied channels) and changed the router location.

Since all of that did not work, I will wait for a Tele2 moderator to answer till tomorrow evening and otherwise call the customer care.

Reputatie 3
Badge +1

Hi Marcel,

Welcome to our forum. Can you send me your full address, date of birth and last 4 digits of your bankaccount number in a private message? This is needed to perform a line measurement. Privébericht naar Michiel

Kind regards, Michiel

Hi there, i got the same issue.

 

Internet is dropping every 5 minutes since 15/02/2020 at 02:00 am im from maastricht, there is any maintenance going on ?