Traag internet & geen portforwarding nat type1

  • 2 oktober 2018
  • 11 reacties
  • 1910 x bekeken

Hopelijk heeft iemand een goede tip voor de volgende situatie:

In het verleden had ik een goede werkende opstelling:
-Tele2 tg789bvn modem
-Eigen modem (openwrt)

De tg789bvn gaf zijn publiek IP door naar mijn eigen modem. In mijn eigen modem had ik een static ip adres ingesteld zoals bij:
https://forum.tele2.nl/randapparatuur-193/nat-type-ps4-open-maken-bij-de-tg789bvn-49337/index2.html

In de tg789bvn had ik een aantal portforwards staan naar het mac adres van mijn eigen router.

Deze opstelling werkte altijd prima.

Na mijn verhuizing heb ik van tele2 een nieuwe ZTE H369A modem gekregen.
Hierin heb ik de volgende instellingen gedaan:
-DHCP assign vast IP adres gezet voor het mac adres van mijn eigen router (192.168.1.x)
-Assign public IP voor het mac adres eigen router
-Port forwards naar mac adres eigen router

In mijn eigen router zie ik het public ip gezet worden (als ik hem op DHCP instel). Vervolgens (net zoals in de oude situatie weer static ip gegeven (extern ip adres)).

Wat opvalt is dat nu het resolven van internet pagina's erg traag is, speedtesten (als de pagina gevonden is) wel volgens verwachting.

Direct internetten op de modem van Tele2 werkt wel snel, dus vraag me af of ik mijn eigen router (openwrt) wel goed heb ingesteld (moet deze wellicht anders worden ingesteld dan de oude tg789bvn modem?).
Ook werken mijn port forwards niet.

Iemand een goede tip?

Dit topic is gesloten. Maak een nieuw topic aan als je een vraag hebt.

11 reacties

Badge +2
Zet de ZTE eens terug in de aflever stand (default dus) en begin met de DMZ op Mac adres van je router. Vul je in bij LAN HOST. En er zijn geen Port Forwardings meer aanwezig. En mag ook niet meer.

Dan naar Local Network, Assign Public IP, vink ON en geeft Mac adres weer op. Let goed op het juiste adres een vergissing is hier gauw gemaakt. Je externe IP wordt hiermee doorgezet naar je router.

Vervolgens naar DHCP Binding, geeft je router een naam en vul verder in: 192.168.1.2. De DHCP Server kun je op ON laten staan.

Start eerst opnieuw de ZTE op en dan je router weer, hij zou de verbinding moeten kunnen vinden.

Heb je het goed gedaan dan kun je de ZTE niet meer bereiken anders dan met een harde reset maar je hebt er ook dan niets meer te zoeken want hij werkt nu slechts als modem en het router gedeelte doet eenvoudig niet meer mee. Bedenk dus van tevoren of je de Wifi hiervan aan of uit wilt hebben.

Alle verdere instellingen die je maar nodig acht doe je nu dus in je eigen router.
Kan met deze opzet er nog wel een ander apparaat aangesloten zijn op de ZTE? Of is deze nu geconfigureerd voor 1 apparaat?
Badge +2
Via de kabel nu dus alleen naar je router toe, want de interne router van de ZTE staat uit omdat de DMZ aan staat. 2 routers in één netwerk geeft heerlijke conflicten. Wel kun je de Wifi gebruiken als je die aan laat staan.
Welke instelling zou ik aan mijn router kant moeten hebben? Dhcp of static ip (extern).

Ik heb voor de test alle 2 de opties getest (dhcp als static) helaas nog zelfde euvel als voorheen, wel internet maar ontzettend traag met resolven van pagina's.
Ook komt er nog steeds geen verkeer binnen via mijn poortforwards (stonden nog in mijn eigen router, niet meer in de zte).

Moet er nog iets anders in mijn eigen router worden aangepast? Masquerading of MMS clamping aan voor de externe lijn?
Badge +2
Hier dan nog een kleine uitleg.

Wat is Masquerading?
Het omzetten van meerdere interne IP-adressen in het netwerk naar een 'officieel' IP-adres. Omdat er zo'n beperkt aantal 'officiële' IP-adressen zijn, richten veel bedrijven hun netwerken in met privé-adressen overeenkomstig met RFC 1918 (10.0.0.0/8, 172.16.0.0/12 en 192.168.0.0/16). Omdat deze adressen niet eenduidig zijn en op het internet niet worden gerouterd, moet de internet-gateway van zo'n privé-netwerk bij alle uitgaande pakketten het adres van de computer door zijn eigen adres vervangen ('maskeren').

MMS Clamping?
Daarmee ga je zitten ‘rommelen’ in de MTU en je moet echt weten wat je dan aan het doen bent. Lijkt me niet dat je dat moet gebruiken.

OpenWRT is een besturingssysteem gebaseerd op de Linux kernel dat specifiek bedoeld is voor routeringsdoeleinden. Doordat het besturingssysteem geoptimaliseerd is voor haar omvang, kan OpenWRT zelfs op embedded devices (routers) draaien die een beperkte hoeveelheid flash- en ROM-geheugen hebben. Het hele verhaal staat in deze link:
https://gathering.tweakers.net/forum/list_messages/1637798/0

Zelf gebruik ik dat niet, ik kies voor de originele software van mijn Asus router die volledig voldoet aan mijn eisen en probleemloos werkt.
Je zal je moeten inlezen in de werking van Linux of weer de originele software op je router zetten.
Dank voor je uitleg.

Inlezen op linux gebied lijkt me niet heel nodig.

Ongeacht welke router software ik gebruik, denk ik dat deze vraag nog steeds relevant is:
"Welke instelling zou ik aan mijn router kant moeten hebben? Dhcp of static ip (extern)?"

Daarnaast vraag ik me af, waarom precies de zelfde instellingen in mijn Openwrt nu niet werken en met mijn oude Tele2 router (tg789bvn) wel.

Is de werking van de ZTE anders dan de tg789bvn?
Vandaag mijn eigen router uplink is in poort 4 van de ZTE gedaan en het IP adres van de ZTE aangepast. Nu lijkt het (voorlopig) naar wens te verlopen.

Ik heb dus nu:
ZTE: 192.168.1.254 port 4 -> naar eigen router
DMZ: UIT
DHCP binding: 192.168.1.2 -> naar mac adres eigen router
Assign public IP -> naar Mac adres eigen router

Eigen router:
Static IP op WAN poort (zoals beschreven in eerdere topics)

Nu alleen port forwarding nog 😅

Deze lijkt in geen enkele manier door te komen naar mijn eigen router. Ik heb hier voor het mac adres gebruikt, dit zou moeten werken zou ik denken?

Iemand een idee?
Badge +2
Je bent er maar druk mee, maar wel een volhouder. Goed zo. Het gaat goed komen zegt men dan.

Wat betreft de poorten 1 t/m 4, dit is gewoon een switch en het maakt niet uit in welke poort de kabel zit. De werking is op alle 4 hetzelfde. Kijk maar eens onder Local Network naar de Lan status. Bij de eerste 3 staat dan oa. “No Link”.

Heb je het ook al geprobeerd met dezelfde instellingen en DMZ aan?

Het maakt overigens niet uit of je nu 1,2,3 of 254 kiest, je hebt de keus tussen 1 tot 254. En je kunt die DHCP Server ook uit zetten.

Voor een buitenstaander die niet in jou configuratie kan kijken is het verder verdraaid lastig om je van een goed antwoord te voorzien. Je geeft geen enkele informatie over jou systeem, welke router laat staan type nummer , waar heb je de apparaten op aangesloten en hoe, op de ZTE of op je ‘eigen’ router. Ik moet eens aan de slag met mijn glazen bol want die laat ook niks zien.

Gokje, zijn je apparaten op je eigen router aan gesloten dan moet je het daarin regelen en is dat niet zo, dan moet die router niet kunnen routeren. Waar gaat welk pakketje heen? Want de router van de ZTE zegt, hey pakketje jij gaat daarheen, niks ervan zegt router 2 dat gaat naar nummer 3 en jij hebt een probleem want wie beslist nou? Snap je?
Hoi Gela,

dank voor je reactie 👍

Ik snap dat wisselen van poortjes of de modem een ander ip geven niet veel zou helpen. Maar voor de duidelijkheid in de oude situatie (met de tg789bvn modem). Werkte deze opstelling. Dus ik heb geen wijzigingen gemaakt in mijn eigen modem (openwrt) behalve het static ip adres aanpassen naar mijn nieuwe ip adres.
Ook de portforwarding in mijn eigen modem werkt, dit kan ik testen doordat ik in mijn interne netwerk wel via de http://eigenrouter:port bij mijn service op mijn server uit kom.

Ik heb een tekening gemaakt van mijn netwerk indeling, hierbij wat extra uitleg.
Rood = extern
Oranje = vsdl lijn van tele2
Blauw = intern netwerk



In de ZTE heb ik de portforwarding (poort 5000) ingesteld naar het MAC adres van mijn eigen router. Mijn eigen router zorgt ervoor dat het pakketje netjes bij mijn server wordt afgeleverd (hier geen wijzigingen gemaakt). Zoals ik al aangeef, het is ook aantoon baar dat mijn eigen router zijn routeer werk nog steeds goed doet.

Verder gebruik ik vaak voor thuiswerken van mijn werk een laptop. Deze wil ik niet op mijn interne netwerk hebben, dus heb ik deze via kabel aangesloten op de ZTE. Vandaar dat ik ook liever geen DMZ op wil zetten, want dan zou ik die mogelijkheid niet meer hebben.

Zelf heb ik wat twijfels over de modem van tele2. Het is gek dat hij op poortje 4 nu ineens wel stabiel internet geeft aan mijn eigen router.
Het is ook gek dat ik geen enkele manier van portforwarding aan de gang krijg of mis ik iets? Werkt de ZTE heel anders dan de tg789bvn?
Badge +2
Duidelijke tekening, nu begint het helder te worden wat je probeert te bereiken.

De opstelling die ik hier heb wijkt niet of nauwelijks af van de tekening die jij laat zien.
Een Synology DS118 fungeert hier als server voor 3 STB’s en een bewakingscamera.
Echter alle apparaten achter mijn router hebben als ip 192.168.2.xxx en een laptop direct op de ZTE heeft 192.168.1.5 Die zit dus op een ander netwerk en kan niet (normaal) achter de router komen.
Met de 3 keer MiMo op 5GHz Mixed (802.11a/n/ac) van de ZTE draait ie alsof hij aan de kabel hangt.


Portforwarding in de ZTE gebruik ik niet en het geheel werkt zonder haperingen inclusief de vpn verbinding naar buiten toe.
Je kunt eens proberen of een dergelijke configuratie ook bij jou goed werkt. Voorbeeld in jou tekening gezet.


Het enige verschil wat ik ervaar met de ZTE ten opzichte van de Technicolor is dat de ZTE een heel stuk prettiger in gebruik is vanwege de duidelijke interface en meer mogelijkheden heeft om iets aan te passen en zeker niet in de laatste plaats de formidabele wifi uitvoering hiervan. Vandaar dat ik ook 2 wifi netwerken in gebruik heb. Dit kan hier omdat de ZTE en mijn ASUS router een flink eind uit elkaar staan.
Na heel wat testen verder kan ik zeggen..... het werkt niet 😥

Ook met dmz komt het verkeer niet aan in mijn eigen router. Dus ik heb zojuist een andere hele simpele test gedaan, ook die zonder goed resultaat.

Test opstelling:
Tele2 router (192.168.1.254):
PC 1: Verbonden aan tele2 router, heeft static ip adres (192.168.1.10)
heeft website op poort 80 draaien.

PC 2: Verbonden aan tele2 router

De tele2 router heeft DMZ uit staan, wel geeft hij een public ip aan mijn eigen router.

PC 1 & PC 2 zitten dus nu niet aan mijn eigen router maar aan de router van tele2.
PC 2 kan de website op PC 1 benaderen, dus firewall settings staan goed.
In de Tele2 router heb ik de volgende portmapping instellingen:
-naam: Test
-Protocol: TCP and UDP
-Lan host: 192.168.1.10
-Wan port: 88 ~ 88
-Lan Host port: 80 ~ 80

Dit is toch echt het basis van het basis voor portmapping zou ik denken. Ik ben een beetje lost nu...

Mijn donkerbruine vermoeden is toch dat de tele2 router alles dicht heeft staan.