beantwoord

Port forward werkt niet davolink 2020

  • 23 augustus 2019
  • 55 reacties
  • 879 x bekeken

Goedemorgen,

Ik probeer al 2 dagen een steam server op te zetten met de oude davolink 2020 modem.
ik heb echt alles geprobeerd maar portforward (virtual servers) werkt gewoon niet. en ben er wel vrij zeker van dat het aan de modem ligt. wat moet ik doen?
icon

Beste antwoord door Malamute 23 augustus 2019, 10:23

Hallo Thias360,

Heb je deze handleiding gevolgd?
Volgens mij zou het daarmee moeten lukken, voor een steamserver moet je dacht ik zowel TCP als UDP forwarden, als je dat niet met 1 regel kan doen in de Davolink zal je er 2 moeten aanmaken.
Bekijk origineel bericht

Dit topic is gesloten. Maak een nieuw topic aan als je een vraag hebt.

55 reacties

Reputatie 7
Badge +4
Helaas.Tele2 geeft verder geen ondersteuning op dit soort vragen. Je ziet ook aan de hulp van specialisten zoals Malamute hoe ingewikkeld de materie is. Daar heeft een standaard klantenservice voor consumentenproducten echt geen kaas van gegeten.
Reputatie 3
Badge +1
Wegens inactiviteit gesloten.
Ik heb mijn firewall uitstaan. De extra regels heb ik zelf gemaakt en loop geprobeerd omdat die gewone regels niet werken. Maar deze ook niet. Het ligt niet aan het modem want ik heb een nieuwe.
Wat zijn de extra regels bij virtual servers naar WAN atm0.1 en atm3.1, werden die automatisch aangemaakt omdat je bij 1 regel nat-loopback hebt aangezet?

Kan je de firewall regels die je hebt aangemaakt op je server voor de steamserver eens plaatsen, ik vermoed dat het eerder daaraan ligt dan aan het modem.

Ik heb mijn firewall uitstaan. De extra regels heb ik zelf gemaakt en loop geprobeerd omdat die gewone regels niet werken. Maar deze ook niet. Het ligt niet aan het modem want ik heb een nieuwe.
Reputatie 4
Badge +2
Open eens een cmd venster en voer netstat -an uit, zie je daar dat er wel geluisterd wordt op de TCP en UDP poorten?

Volgens deze installatie pagina: https://ark.gamepedia.com/Dedicated_Server_Setup
klopt je query poort niet, 27020 mag geen query poort zijn:
*Notes*
Query Port cannot be between 27020 and 27050 due to Steam using those ports.

Dus misschien start die server wel maar reageert hij niet omdat de verkeerde poort staat ingesteld.

Deze poorten zou je moeten gebruiken en dus bij portforward moeten instellen:
UDP 27015 Query port for Steam's server browser
UDP 7777 Game client port
UDP 7778 Raw UDP socket port (always Game client port +1)
TCP 27020 RCON for remote console server access (optional)
Open eens een cmd venster en voer netstat -an uit, zie je daar dat er wel geluisterd wordt op de TCP en UDP poorten?

Volgens deze installatie pagina: https://ark.gamepedia.com/Dedicated_Server_Setupklopt je query poort niet, 27020 mag geen query poort zijn:
*Notes*
Query Port cannot be between 27020 and 27050 due to Steam using those ports.

Dus misschien start die server wel maar reageert hij niet omdat de verkeerde poort staat ingesteld.

Deze poorten zou je moeten gebruiken en dus bij portforward moeten instellen:
UDP 27015 Query port for Steam's server browser
UDP 7777 Game client port
UDP 7778 Raw UDP socket port (always Game client port +1)
TCP 27020 RCON for remote console server access (optional)


Het mag wel 27020 maar ik gebruik normaal altijd 27015. Maar die werkte niet. Ik kan nu even niet netstat - an doen omdat ik linux heb geistalleerd en de server daarop aan het installeren is nu. (Ubuntu 18.04). Ik zal zo weer even een bericht plaatsen of het lukt met de porten.
Nou ik heb linux geinstalleerd en de server draait weer. Alleen nog steeds zelfde verhaal de porten zijn niet open
Als die poorten echt nog geblokkeerd zijn moet Tele2 het oplossen volgens de regels die de EU heeft opgelegd.

Wat is netneutraliteit?

In Europa mogen internetaanbieders verschillende vormen van internetverkeer niet verschillend behandelen. Dat betekent: niet blokkeren en niet onnodig beperken.


Tele2 heeft toch ook zelf een klantenservice pagina opgezet hoe je portforwarding instelt, bijzonder vreemd dat de Tele2 klantenservice dan telefonisch beweert dat het niet mogelijk is.


Waarschijnlijk gaan ze dit toch niet oplossen dus overstappen naar Caiway is een prima optie, vriend van mij heeft Caiway en daar staan de poorten gewoon open van buitenaf.


hi malamute.

ik heb tele2 opgezegd en heb nu een Caiway abbonement! het is veel sneller internet 120mbps en port forward lukt ook nu. en de server draait! met poort 27015 en 7778. ☺

nou heb ik deze gevolgd en ik krijg nog steeds dit. (Bij step 3 internet connection) https://steamcommunity.com/app/346110/discussions/0/615086038683861456/
Reputatie 4
Badge +2
Als de steamserver niet draait zal je i.d.d. geen open poorten zien.

Wat staat er in die startup.sh (wel even je paswoorden vervangen door wat anders)

Wat step 3 in die link er mee te heeft snap ik niet, dat hele verhaal gaat over een steamserver op windows via een linux router, dat laatste is in feite hetzelfde als wat je al in je Tele2 modem/router gedaan hebt (portforwarding).

Met lsof -i -n -P kan je zien welke verbindingen er zijn en op welke poorten er geluisterd wordt door de verschillende processen op je linux server.
Als de steamserver niet draait zal je i.d.d. geen open poorten zien.

Wat staat er in die startup.sh (wel even je paswoorden vervangen door wat anders)

Wat step 3 in die link er mee te heeft snap ik niet, dat hele verhaal gaat over een steamserver op windows via een linux router, dat laatste is in feite hetzelfde als wat je al in je Tele2 modem/router gedaan hebt (portforwarding).

Met lsof -i -n -P kan je zien welke verbindingen er zijn en op welke poorten er geluisterd wordt door de verschillende processen op je linux server.

de server was aan het draaien toen. No open port between 27015 zegtie als ik de server aanzet. Soms zegtie dat soms niet. Dan alleen die s_api fail zin. En ik heb queryport en port en zo later toegevoegd... Met hetzelfde resultaat. En lsof -i -n -P doet niks. Ik denk dat ik ff een schone installatie van windows 10 ga doen en dan ff weer de server opzetten de uitzonderingen in de firewall toevoegen en de port forward opnieuw in de modem. En dan doe ik wel ff netstat -an in cmd.
Reputatie 4
Badge +2
Voor dat lsof commando moet je dan sudo zetten, als gewone gebruiker mag je blijkbaar niet zien welke poorten openstaan.

Je Ubuntu server draait wel maar als ark/steam-server niet gestart is gebeurt er niets op die poorten dus zie je ze niet als open poort.
Het heeft weinig zin om steeds te switchen tussen windows en linux.

Als script zou je beter die van de Server_setup webpage kunnen gebruiken:
code:
#! /bin/bash
./ShooterGameServer TheIsland?listen?SessionName=?ServerPassword=?ServerAdminPassword= -server -log


en dus geen poorten toevoegen, die zouden automatisch ingesteld moeten worden.
Reputatie 4
Badge +2
Hoi Thias360,

Bedankt voor de terugkoppeling, fijn dat het nu wel werkt. ☺

Het lag dus i.d.d. aan de illegale poortblokkade van Tele2. 😡
Voor dat lsof commando moet je dan sudo zetten, als gewone gebruiker mag je blijkbaar niet zien welke poorten openstaan.

Je Ubuntu server draait wel maar als ark/steam-server niet gestart is gebeurt er niets op die poorten dus zie je ze niet als open poort.
Het heeft weinig zin om steeds te switchen tussen windows en linux.

Als script zou je beter die van de Server_setup webpage kunnen gebruiken:
code:
#! /bin/bash
./ShooterGameServer TheIsland?listen?SessionName=?ServerPassword=?ServerAdminPassword= -server -log



en dus geen poorten toevoegen, die zouden automatisch ingesteld moeten worden.


Ik heb het zonder die porten ook geprobeerd. En hij draait wel want ik check op een ark server website of hij draait. Dan staat er online maar de porten staan niet open dus ik kom er niet in via steam. Maar ik heb windows geistalleerd en geupdate en ben nou de arkserver aan het installeren. Daarna zal ik de firewall regels toevoegen, de modem resetten en port forward weer toevoegen. En netstat -an doen in cmd. Ff kijken watie dan zegt.
Hoi Thias360,

Bedankt voor de terugkoppeling, fijn dat het nu wel werkt. ☺


Het lag dus i.d.d. aan de illegale poortblokkade van Tele2. 😡


Ja...
Reputatie 3
Badge +1
denk je dat ik een nieuwe modem kan krijgen omdat dit niet meer werkt?

Ik heb even alles doorgelezen en het is jammer dat het niet is gelukt en daarom wil ik je ook een ander modem toe sturen. Ik heb dan de volgende gegevens van je nodig.

  • Naam
  • Adres
  • Postcode + Woonplaats
  • Geboortedatum
  • Laatste vier cijfers van je IBAN nummer
Gebruik deze link om mij een privébericht te sturen: Privébericht naar Anton.

Alvast bedankt.

Groeten Anton
ok
Reputatie 7
Badge +4
Big advise! Haal die plaatjes direct weg. Dit is vragen om ddos aanvallen! Veel te veel persoonlijke informatie.
Big advise! Haal die plaatjes direct weg. Dit is vragen om ddos aanvallen!

Ik heb windows net opnieuw geistalleerd. Maakt mij niet uit. Ik wil weten waarom het nog steeds niet werkt!

Big advise! Haal die plaatjes direct weg. Dit is vragen om ddos aanvallen!Ik heb windows net opnieuw geistalleerd. Maakt mij niet uit. Ik wil weten waarom het nog steeds niet werkt! Ik kan ze zometeen wel weer weghalen als malamute ze gelezen heeft.
Reputatie 7
Badge +4
Vraag dan aan @Malamute een direct communicatie mogelijkheid. Het lijkt erop alsof hij je het best kan en wil helpen. Je hebt tot 1 uur na posting om berichten te bewerken.
Vraag dan aan @Malamute een direct communicatie mogelijkheid. Het lijkt erop alsof hij je het best kan en wil helpen. Je hebt tot 1 uur na posting om berichten te bewerken.


prima
Reputatie 4
Badge +2
Ik heb ze gezien maar in deze plaatjes staat niets bijzonders, in 1 van je eerdere plaatjes staat wel je serveradminpaswoord, die zou ik dus veranderen, de servernaam en adminpaswoord staan er ook in, als die ook niet algemeen bekend mogen zijn moet je die ook veranderen.

IP-adres verbergen heeft tegenwoordig geen zin, zet maar eens een remote desktop open, binnen no-time proberen ze daarop in te loggen zelfs als je een andere poort instelt. Elke ip-adres wordt tegenwoordig zowat continue gescanned.

Je mag de plaatjes nu ook verwijderen.

In je portforwarding heb je nu alleen 7777 geforward en niet 7777 t/m 7779.
Volgens netstat luistert de server op 7778, ook 27015 staat wel open.
Reputatie 7
Badge +4
In je portforwarding heb je nu alleen 7777 geforward en niet 7777 t/m 7779.
Volgens netstat luistert de server op 7778, ook 27015 staat wel open.


Scherp!
Ik heb ze gezien maar in deze plaatjes staat niets bijzonders, in 1 van je eerdere plaatjes staat wel je serveradminpaswoord, die zou ik dus veranderen, de servernaam en adminpaswoord staan er ook in, als die ook niet algemeen bekend mogen zijn moet je die ook veranderen.

IP-adres verbergen heeft tegenwoordig geen zin, zet maar eens een remote desktop open, binnen no-time proberen ze daarop in te loggen zelfs als je een andere poort instelt. Elke ip-adres wordt tegenwoordig zowat continue gescanned.

Je mag de plaatjes nu ook verwijderen.

In je portforwarding heb je nu alleen 7777 geforward en niet 7777 t/m 7779.
Volgens netstat luistert de server op 7778, ook 27015 staat wel open.


ok ik heb nu ook 7778 en 7779 erbij gezet in de modem en firewall tcp en udp apart net als de rest. en server afgesloten en weer opgestart. moet ik een foto plaatsen van netstat -an?